错误: -source 1.6 中不支持 diamond 运算符 (请使用 -source 7 或更高版本以启用 diamond 运算符)

今天晚上在AS上运行校长项目时,报错如下:

Error:(71, 35) 错误: -source 1.6 中不支持 diamond 运算符(请使用 -source 7 或更高版本以启用 diamond 运算符)

这个错误对应程序里的代码是:

错误


一般正确的写法是在声明的时候指定类型,也就是:

List<PublicBlogListBean>  _hotDatas = new ArrayList<PublicBlogListBean>();


但是在JDK 1.7里新增了一个新特性:

      增强对通用实例创建(diamond)的类型推断
             类型推断是一个特殊的烦恼,下面的代码: 
             Map<String, List<String>> anagrams = new HashMap<String, List<String>>(); 

             通过类型推断后变成: 
             Map<String, List<String>> anagrams = new HashMap<>(); 
             这个<>被叫做diamond(钻石)运算符,这个运算符从引用的声明中推断类型。 


也就是说JDK1.7支持这种类型推断后,在声明_hotDatas 时new ArrayList<>里可以不需要加上PublicBlogListBean类型


截图中的错误也提示了:-soure1.6中不支持diamond运算符,Diamond types are not supported at this language level。说明目前使用的JDK版本不支持,但是Project此时的JDK路径正是1.7的版本,这...


事实上项目里还没有对module做源码兼容性的配置,即设置 Source Compatibility和Target Compatibility为1.7:

版本

点击ok会后gradle重新构建,确定reload Project下就好啦~

运算符


也可以在build.gradle里直接配置:

运算符

使用


查找的相关资源:

jdk1.7新特性

AndroidGradlePlugin指南(六)高级构建定制



您的回应...

相关话题

查看全部

也许你感兴趣

换一批

热门标签

更多